InterVlan Routing between L3 Switch and Router By Networking Hub

Intervlan Routing Scenario Configuration.


In this blog, we are going to configure InterVLAN routing between Layer-3 switches and a Router. We can use this lab for two below scenarios.

1. InterVLAN Routing Lab.
2. How To Configure Layer -3 switch to the internet.




LAYER-3 SWITCH CONFIGURATION:

Firstly switch side we will create three VLAN (100-102) and configure the IP address for each VLANs.

After IP addressing of VLAN, we will configure the router connected interface as a trunk.


Press RETURN to get started!



Switch>en

Switch#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname LANswitch

LANswitch(config)#Vlan 101
LANswitch(config-vlan)#Vlan 102
LANswitch(config-vlan)#Vlan 100

LANswitch#config t
LANswitch(config)#int Vlan 100
LANswitch(config-if)#ip address 100.10.10.1 255.255.255.0
LANswitch(config-if)#no shutdown 
LANswitch(config-if)#int Vlan 101


LANswitch(config-if)#ip address 100.10.20.1 255.255.255.0
LANswitch(config-if)#no shutdown 
LANswitch(config-if)#int Vlan 102


LANswitch(config-if)#ip address 100.10.30.1 255.255.255.0

LANswitch#config t
LANswitch(config)#int fastEthernet 0/1
LANswitch(config-if)#Switchport trunk encapsulation dot1q 
LANswitch(config-if)#switchport mode trunk 
LANswitch(config-if)#Switchport trunk allowed vlan all

ROUTER CONFIGURATION:

On the router side, We will first configure the interfaces which are connected to the Layer-3 switch.

Router>en
Router#config t
]Router(config)#Int FastEthernet 0/0
Router(config-if)#no shutdown 
Router(config-if)#Int fastEthernet 0/0.100
Router(config-subif)#ip address 100.10.10.2 255.255.255.0
Router(config-subif)#encapsulation dot1Q 100
Router(config-subif)#ip address 100.10.10.2 255.255.255.0
Router(config)#Int FastEthernet 0/0.101
Router(config-subif)#encapsulation dot1Q 101
Router(config-subif)#ip address 100.10.20.2 255.255.255.0
Router(config-subif)#Int fastEthernet 0/0.102
Router(config-subif)#encapsulation dot1Q 102
Router(config-subif)#ip address 100.10.30.2 255.255.255.0

TESTING:


We can test the connection by ICMP response.

ROUTER SIDE:

Router#ping 100.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4294967295 ms

Router#ping 100.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms

Router#ping 100.10.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.20.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms

Router#ping 100.10.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.30.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms

SWITCH SIDE:

LANswitch#ping 100.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

LANswitch#ping 100.10.20.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.20.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

LANswitch#ping 100.10.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/5 ms

LANswitch#ping 100.10.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.10.30.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/2 ms'




This video is in the Hindi Language (यह वीडियो हिंदी भाषा में है)

8 Comments

  1. A wireless router is a gadget that interfaces with your home or office modem, so you may associate numerous gadgets, regularly wired and wireless to your web association simultaneously. best budget router

    ReplyDelete
  2. A remote switch is a gadget that permits all the PCs and convenient gadgets in your home to share an Internet association. It fundamentally builds up a system to interface every one of your gadgets.jiofi.local.html

    ReplyDelete
  3. Wow, cool post. I'd like to write like this too - taking time and real hard work to make a great article... but I put things off too much and never seem to get started. Thanks though. cable Tray manufacturers in Pakistan

    ReplyDelete
  4. I like to recommend exclusively fine plus efficient information and facts, hence notice it: website link

    ReplyDelete
  5. Hence it is better you have to affiliated understand when setting up. It is easy to put up a lot better apply for right away. Graphics Design

    ReplyDelete
  6. nice bLog! its interesting. thank you for sharing.... Desktop server rams in Kenya

    ReplyDelete
  7. A switch bit is a cutting device utilized with a switch to defeat out (or burrow out) spaces in the outside of a by and large hard workpiece. In spite of the fact that switches and switch pieces are all the more generally utilized in carpentry applications like cabinetry and carpentry, these cutting apparatuses can likewise act in metals, plastics and different materials.router ip

    ReplyDelete
Previous Post Next Post