Network Routing and switching scenario configuration.


Network Diagram:







Configuration:

ISP Router:

Router>enable
Router>#configure terminal
Router(config)#hostname ISProuter
ISProuter(config)#interface loopback 0
ISProuter(config-if)#description simulated address representing remote website
ISProuter(config-if)#ip address 198.133.219.1 255.255.255.0
ISProuter(config-if)#interface serial 3/0
ISProuter(config-if)#description WAN link to the Corporate Router
ISProuter(config-if)#ip address 192.31.7.5 255.255.255.252
ISProuter(config-if)#clock rate 56000
ISProuter(config-if)#no shutdown
ISProuter(config-if)#exit
ISProuter(config-if)#router eigrp 10
ISProuter(config-router)#network 198.133.219.0
ISProuter(config-router)#network 192.31.7.0
ISProuter(config-router)#no auto-summary
ISProuter(config-router)#exit
ISProuter#write memory


Corp Router


Router>enable
Router>#configure terminal
Router(config)#hostname Corprouter
Corprouter(config)#no ip domain-lookup
Corprouter(config)#interface serial 2/0
Corprouter(config-if)#description link to ISProuter
Corprouter(config-if)#ip address 192.31.7.6 255.255.255.252
Corprouter(config-if)#no shutdown
Corprouter(config)#interface fastethernet 0/1
Corprouter(config-if)#description link to 3560 Switch
Corprouter(config-if)#ip address 172.31.1.5 255.255.255.252
Corprouter(config-if)#no shutdown
Corprouter(config-if)#exit
Corprouter(config)#router eigrp 10
Corprouter(config-router)#network 172.31.0.0
Corprouter(config-router)#network 192.31.7.0
Corprouter(config-router)#no auto-summary
Corprouter(config-router)#exit
Corprouter# write memory


L3 Switch:

Switch>enable
Switch#configure terminal
Switch(config)#hostname L3sw
L3sw(config)#no ip domain-lookup
L3sw(config)#vlan 10
L3sw(config-vlan)#name Accounting
L3sw(config-vlan)#exit
L3sw(config)#vlan 20
L3sw(config-vlan)#name MGMT
L3sw(config)#vlan 30
L3sw(config-vlan)#name IT
L3sw(config)#vlan 40
L3sw(config-vlan)#name Sales
L3sw(config-vlan)#exit
L3sw(config)#interface
gigabitethernet 0/1
L3sw(config-if)#switchport trunk encapsulation dot1q
L3sw(config-if)#switchport mode trunk
L3sw(config-if)#exit
L3sw(config)#ip routing
L3sw(config)#interface vlan 10
L3sw(config-if)#ip address 192.168.10.1 255.255.255.0
L3sw(config-if)#no shutdown
L3sw(config-if)#interface vlan 20
L3sw(config-if)#ip address 192.168.20.1 255.255.255.0
L3sw(config-if)#no shutdown
L3sw(config-if)#interface vlan 30
L3sw(config-if)#ip address 192.16.30.1 255.255.255.0
L3sw(config-if)#no shutdown
L3sw(config-if)#exit
L3sw(config-if)#interface vlan 40
L3sw(config-if)#ip address 192.16.40.1 255.255.255.0
L3sw(config-if)#no shutdown
L3sw(config)#router eigrp 10
L3sw(config-router)#network 192.168.10.0
L3sw(config-router)#network 192.168.20.0
L3sw(config-router)#network 192.168.30.0
L3sw(config-router)#network 192.168.40.0
L3sw(config-router)#network 172.31.0.0
L3sw(config-router)#no auto-summary
L3sw(config-router)#exit
L3sw(config)#exit

L3sw#Write memory


L2 Switch:


Switch>enable
Switch#configure terminal
Switch(config)#hostname L2Switch
L2Switch(config)#no ip domain-lookup
L2Switch(config)#vlan 10
L2Switch(config)#vlan 20
L2Switch(config-vlan)#vlan 30
L2Switch(config-vlan)#exit
L2Switch(config)#interface fastethernet 0/2
L2Switch(config-if-range)#switchport mode access
L2Switch(config-if-range)#switchport access vlan 10
L2Switch(config-if-range)#interface fastethernet 0/3
L2Switch(config-if-range)#switchport mode access
L2Switch(config-if-range)#switchport access vlan 20
L2Switch(config-if-range)#interface fastethernet 0/4
L2Switch(config-if-range)#switchport mode access
L2Switch(config-if-range)#switchport access vlan 30
L2Switch(config-if-range)#exit
L2Switch(config)#interface fastethernet 0/1
L2Switch(config-if)#switchport mode trunk
L2Switch(config-if)#exit
L2Switch(config)#exit
L2Switch#write Memory


No comments