RIP Basic Configuration Example:

RIP Overview:

RIP stands for Routing Information Protocol which is a distance vector routing protocol. RIP sends the complete routing table out to all active interfaces in every 30 seconds interval. RIP uses hop count to determine the best path to a remote network, but it has a maximum allowable hop count of 15, the meaning that 16 is deemed unreachable. RIP is good for small networks, but it’s not valuable for large networks with slow WAN links or on that networks in which a large number of routers installed. RIP version 1 only supports classful routing, which means that all connected devices in the network must use the same subnet mask. This is because RIP version 1 doesn’t send updates with subnet mask information in the network. RIP version 2 provides something called prefix routing or classless routing and does send subnet mask information with the route updates. 

Network Topology:



In this topology we have two routers which are connected with subnets 192.168.10.0/24 and Routers inter-network have different different subnets. In this Lab we are going to configure RIPv2 for communication of all inter-network subnets.

IP addressing Configuration:

Router1

Router1#config t
Router1(config)#int gigabitEthernet 0/0
Router1(config-if)#Ip address 192.168.10.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#int gigabitEthernet 0/1
Router1(config-if)#Ip address 10.10.10.1 255.255.255.0

Router1(config-if)#no shutdown

Router2:

Router2#config t
Router2(config)#int gigabitEthernet 0/0
Router2(config-if)#Ip address 192.168.10.2 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#int gigabitEthernet 0/1
Router2(config-if)#Ip address 10.10.20.1  255.255.255.0

Router2(config-if)#no shutdown


RIP Configuration:

Router1:

Router1(config)#router rip
Router1(config-router)#version 2
Router1(config-router)#network 192.168.10.0
Router1(config-router)#network 10.10.10.0

Router2:

Router2(config)#router rip
Router2(config-router)#version 2
Router2(config-router)#network 192.168.10.0
Router2(config-router)#network 10.10.20.0

Testing :


No comments