Exterior Border Gateway Protocol (EBGP) Configuration Example.


The EBGP multihop is a Cisco IOS option that must be configured on each peer (Neighbor). The EBGP multihop keyword is used only for eBGP sessions, not for Interior BGP. eBGP neighbors are generally directly connected to establish an eBGP session.Sometimes one of the directly connected routers is unable to run BGP. That time EBGP multihop keyword allows for a logical connection to be made between peer routers even if they are not using directly connected interfaces. 

Interface IP addressing On Router -1:

Router>en
Router1(config)#int GigabitEthernet 0/0
Router1(config-if)#Ip address 192.168.10.1 255.255.255.0
Router1(config-if)#no shutdown

Router1(config)#int Loopback 0
Router1(config-if)#ip address 1.1.1.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit

EBGP Configuration on Router-1:

Router1(config)#ip route 2.2.2.2 255.255.255.0 192.168.10.2
Router1(config)#router bgp 100
Router1(config-router)#neighbor 2.2.2.2 remote-as 200
Router1(config-router)#neighbor 2.2.2.2 update-source loopback0
Router1(config-router)#neighbor 2.2.2.2 EBGP-multihop 2

Interface IP addressing On Router -2:

Router2>en
Router2#config t
Router2(config)#int GigabitEthernet 0/0
Router2(config-if)#Ip address 192.168.10.2 255.255.255.0
Router2(config-if)#no shutdown

EBGP Configuration on Router-2:

Router2(config)#int loopback 0
Router2(config-if)#ip address 2.2.2.2 255.255.255.0
Router2(config-if)#no shutdown

Router2(config)#ip route 1.1.1.1 255.255.255.0 192.168.10.1
Router2(config)#router bgp 200
Router2(config-router)#neighbor 1.1.1.1 remote-as 100
Router2(config-router)#neighbor 1.1.1.1 update-source loop- back0
Router2(config-router)#neighbor 1.1.1.1 EBGP-multihop 2

Verify EBGP:

Router1#
Router1#Sh ip bgp summary

Neighbor          V  AS     MsgRcvd    MsgSent.  TblVer InQ OutQ  Up/Down   State/PfxRcd
2.2.2.2              4 200         0                  0                 1          0      0      00:47:58          4

192.168.10.2    4 200         2                  2                 1          0      0      00:00:04          4

Router2#sh ip bgp summary

Neighbor             V AS MsgRcvd MsgSent.   TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1                 4 100      0             0                   1          0         0     00:52:11         4

192.168.10.1       4 100      6             6                   1          0         0     00:04:20         4

No comments