GRE Tunnel Configuration Example:

The network topology for the configuration shows how to configure a GRE tunnel between two remote sites (Branch and HQ). This blog shows only the commands needed to set up the GRE tunnel. Other commands are necessary to complete the configuration like host names, physical interfaces, routing, and so on.

Network topology:

Branch Router Configuration:

BranchRouter(config)#interface tunnel0
BranchRouter(config-if)#tunnel mode gre ip
BranchRouter(config-if)#ip address 192.168.100.1 255.255.255.0
BranchRouter(config-if)#tunnel source 63.64.57.1
BranchRouter(config-if)#tunnel destination 10.135.157.1

HQ Router Configuration:

HQRouter(config)#interface tunnel0
HQRouter(config-if)#tunnel mode gre ip
HQRouter(config-if)#ip address 192.168.100.2 255.255.255.0
HQRouter(config-if)#tunnel source 10.135.157.1
HQRouter(config-if)#tunnel destination 63.64.57.1


Verify GRE Tunnel:

HQRouter#show interface tunnel0

HQRouter#show ip interface brief

HQRouter#show ip interface brief | include tunnel

HQRouter#show ip route



No comments