Port Address Translation Configuration Example:




Hi Guys,
In this blog we will work on Port Address Translation scenarios configuration. As per the Scenarios we have two router in below topology. ISP router is connected with Company core router with Gigabit interfaces. We are using Public address between  ISP and core router and Private address for internal network.



ISP Router Configuration:

router>enable
router#configure terminal
router(config)#hostname ISPRouter
ISPRouter(config)#no ip domain-lookup
ISPRouter(config)#enable secret cisco
ISPRouter(config)#line console 0
ISPRouter(config-line)#login
ISPRouter(config-line)#password Networkinghub
ISPRouter(config-line)#logging synchronous

ISPRouter(config-line)#exit
ISPRouter(config)#interface gigabitethernet 0/0
ISPRouter(config-if)#ip address 63.64.58.1 255.255.255.224
ISPRouter(config-if)#clock rate 56000
ISPRouter(config-if)#no shutdown
ISPRouter(config-if)#exit
ISPRouter(config)#exit
ISPRouter#copy running-config
startup-config

Core Router Configuration:

router>enable
router#configure terminal
router(config)#hostname CoreRouter
CoreRouter(config)#no ip domain-lookup
CoreRouter(config)#enable secret cisco
CoreRouter(config)#line console 0
CoreRouter(config-line)#login
CoreRouter(config-line)#password class
CoreRouter(config-line)#logging synchronous
CoreRouter(config-line)#exit
CoreRouter(config)#interface gigabitethernet 0/0
CoreRouter(config-if)#ip address 192.168.10.1 255.255.255.0
CoreRouter(config-if)#no shutdown
CoreRouter(config-if)#int gigabitethernet 0/1
CoreRouter(config-if)#ip address 63.64.58.2 255.255.255.224
CoreRouter(config-if)#no shutdown
CoreRouter(config-if)#exit
CoreRouter(config)#ip route 0.0.0.0
0.0.0.0 63.64.58.1
CoreRouter(config)#access-list 1 permit 192.168.10.0 0.0.0.255
CoreRouter(config)#ip nat inside source list 1 interface gigabitethernet 0/1 overload
CoreRouter(config)#interface gigabitethernet 0/0
CoreRouter(config-if)#ip nat inside
CoreRouter(config-if)#interface gigabitethernet 0/1
CoreRouter(config-if)#ip nat outside
CoreRouter(config-if)#exit
CoreRouter#copy running-config startup-config


Verify PAT:

Router#show access-list
Router#show ip nat translations
Router#show ip nat statistics

Router#clear ip nat translation*

No comments